Логическая функция в excel если. Логические функции в Excel

Логические функции в програмке Microsoft Excel

Среди множества разных выражений, которые используются при работе с Microsoft Excel, следует выделить логические функции. Их используют для указания выполнения разных критерий в формулах. При этом, ежели сами условия могут быть достаточно различными, то итог логических функций может принимать всего два значения: условие выполнено (ИСТИНА) и условие не выполнено (ЛОЖЬ). Давайте подробнее разберемся, что представляют собой логические функции в Экселе.

Основные операторы

Существует несколько операторов логических функций. Посреди главных следует выделить такие:

  • ИСТИНА;
  • ЛОЖЬ;
  • ЕСЛИ;
  • ЕСЛИОШИБКА;
  • ИЛИ;
  • И;
  • НЕ;
  • ЕОШИБКА;
  • ЕПУСТО.

Существуют и наименее всераспространенные логические функции.

У каждого из вышеуказанных операторов, не считая первых 2-ух, имеются аргументы. Аргументами могут выступать, как определенные числа либо текст, так и ссылки, указывающие адресок ячеек с данными.

Функции ИСТИНА и ЛОЖЬ

Оператор ИСТИНА воспринимает лишь определенное данное значение. У данной функции отсутствуют аргументы, и, как правило, она фактически постоянно является составной частью наиболее сложных выражений.

Оператор ЛОЖЬ, напротив, воспринимает хоть какое значение, которое не является истиной. Точно так же эта функция не имеет аргументов и заходит в наиболее сложные выражения.

Функции И и ИЛИ

Функция И является связывающим звеном меж несколькими критериями. Лишь при выполнении всех критерий, которые связывает данная функция, она возвращает значение ИСТИНА. Ежели хотя бы один аргумент докладывает значение ЛОЖЬ, то и оператор И в целом возвращает это же значение. Общий вид данной функции: . Функция может включать в себя от 1 до 255 аргументов.

Функция ИЛИ, напротив, возвращает значение ИСТИНА даже в том случае, ежели лишь один из аргументов отвечает условиям, а все другие ложные. Её шаблон имеет последующий вид: . Как и предшествующая функция, оператор ИЛИ может включать в себя от 1 до 255 условий.

Функция НЕ

В отличие от 2-ух прошлых операторов, функция НЕ имеет всего только один аргумент. Она меняет значение выражения с ИСТИНА на ЛОЖЬ в пространстве указанного аргумента. Общий синтаксис формулы смотрится последующим образом: .

Функции ЕСЛИ и ЕСЛИОШИБКА

Для наиболее сложных конструкций употребляется функция ЕСЛИ. Данный оператор показывает, какое конкретно значение является ИСТИНА, а какое ЛОЖЬ. Его общий шаблон смотрится последующим образом: . Таковым образом, ежели условие соблюдается, то в ячейку, содержащую данную функцию, заполняют заблаговременно указанные данные. Ежели условие не соблюдается, то ячейка заполняется иными данными, указанными в 3-ем по счету аргументе функции.

Оператор ЕСЛИОШИБКА, в случае ежели аргумент является истиной, возвращает в ячейку его собственное значение. Но, ежели аргумент ошибочный, тогда в ячейку ворачивается то значение, которое показывает юзер. Синтаксис данной функции, содержащей всего два аргумента, смотрится последующем образом: .

Урок: функция Ежели в Excel

Функции ЕОШИБКА и ЕПУСТО

Функция ЕОШИБКА инспектирует, не содержит ли определенная ячейка либо спектр ячеек ошибочные значения. Под ошибочными значениями понимаются следующие:

  • #Н/Д;
  • #ЗНАЧ;
  • #ЧИСЛО!;
  • #ДЕЛ/0!;
  • #ССЫЛКА!;
  • #ИМЯ?;
  • #ПУСТО!

В зависимости от того ошибочный аргумент либо нет, оператор докладывает значение ИСТИНА либо ЛОЖЬ. Синтаксис данной функции следующий: . В роли аргумента выступает только ссылка на ячейку либо на массив ячеек.

Оператор ЕПУСТО делает проверку ячейки на то, пустая ли она либо содержит значения. Ежели ячейка пустая, функция докладывает значение ИСТИНА, ежели ячейка содержит данные – ЛОЖЬ. Синтаксис этого оператора имеет таковой вид: . Так же, как и в прошлом случае, аргументом выступает ссылка на ячейку либо массив.

Пример внедрения функций

Теперь давайте разглядим применение неких из перечисленных выше функций на определенном примере.

Имеем перечень работников компании с положенными им заработными платами. Но, не считая того, всем работникам положена премия. Рядовая премия составляет 700 рублей. Но пенсионерам и дамам положена завышенная премия в размере 1000 рублей. Исключение составляют работники, по разным причинам проработавшие в данном месяце наименее 18 дней. Им в любом случае положена лишь рядовая премия в размере 700 рублей.

Попробуем составить формулу. Итак, у нас существует два условия, при выполнении которых положена премия в 1000 рублей – это достижение пенсионного возраста либо принадлежность работника к женскому полу. При этом, к пенсионерам отнесем всех тех, кто родился ранее 1957 года. В нашем случае для первой строки таблицы формула воспримет таковой вид: . Но, не забываем, что неотклонимым условием получения завышенной премии является отработка 18 дней и наиболее. Чтоб ввести данное условие в нашу формулу, применим функцию НЕ: .

Для того, чтоб скопировать данную функцию в ячейки столбца таблицы, где указана величина премии, становимся курсором в нижний правый угол ячейки, в которой уже имеется формула. Возникает маркер наполнения. Просто перетягиваем его вниз до конца таблицы.

Читайте также  Диск заполнен но файлов не видно. Не видимые файлы на внешнем Hdd

Таким образом, мы получили таблицу с информацией о величине премии для каждого работника компании в отдельности.

Урок: полезные функции Excel

Как лицезреем, логические функции являются чрезвычайно комфортным инвентарем для проведения расчетов в програмке Microsoft Excel. Используя сложные функции, можно задавать несколько критерий сразу и получать выводимый итог в зависимости от того, выполнены эти условия либо нет. Применение схожих формул способно заавтоматизировать целый ряд действий, что содействует экономии времени юзера.

Мы рады, что смогли посодействовать Для вас в решении проблемы.

Добавьте веб-сайт в закладки и мы еще пригодимся для вас.

Опишите, что у вас не вышло. Наши спецы постараются ответить очень быстро.

Помогла ли для вас эта статья?

ДАНЕТ

Поделиться статьей в соц сетях:

Функция Ежели в Excel – примеры использования

Функция Ежели в Excel – это одна из самых обычных функций. Конкретно потому она является одной из главных и при этом она чрезвычайно полезна.

Сейчас мы на примерах разглядим, как можно применять функцию Ежели в Excel, а также какие задачки мы можем решить с ее помощью.

Что делает функция ЕСЛИ?

Она дозволяет сделать дерево решений, в котором при выполнении какого-то условия происходит определенное действие. А ежели это условие не выполняется, то совершается другое действие.

При этом  аргумент функции должен быть вопросцем, на который может быть 2 варианта ответа: «да» и «нет», “истина” либо “ложь”.

Вот как может смотреться это дерево решений.

Итак, функция Ежели дозволяет задать вопросец и указать на 2 варианта вычислений в зависимости от приобретенного на него ответа. Они и являются 3-мя аргументами функции.

Синтаксис функции ЕСЛИ

Вот как смотрится синтаксис данной функции и её аргументы:

=ЕСЛИ(логическое выражение, значение ежели «да», значение ежели «нет»)

Логическое выражение – (обязательное) условие, которое возвращает значение «истина» либо «ложь» («да» либо «нет»);

Значение ежели «да» – (обязательное) действие, которое выполняется в случае положительного ответа;

Значение ежели «нет» – (обязательное) действие, которое выполняется в случае отрицательного ответа;

Давайте вкупе подробнее разглядим эти аргументы.

Первый аргумент – это логический вопросец. И ответ этот может быть лишь «да» либо «нет», «истина» либо «ложь».

Как верно задать вопрос? Для этого можно составить логическое выражение, используя знаки “=”, “>”, “<”, “>=”, “<=”, “<>”. Давайте попробуем задать таковой вопросец вместе.

Простейший пример применения.

Предположим, вы работаете в компании, которая занимается продажей шоколада в пары регионах и работает с обилием покупателей.

Нам нужно выделить реализации, которые произошли в нашем регионе, и те, которые были изготовлены за рубежом. Для этого необходимо добавить в таблицу ещё один признак для каждой реализации – страну, в которой она произошла. Мы желаем, чтоб этот признак создавался автоматом для каждой записи (то есть, строки).

В этом нам поможет функция Ежели. Добавим в таблицу данных столбец “Страна”. Регион “Запад” – это местные реализации («Местные»), а другие регионы – это реализации за предел («Экспорт»).

Как верно записать?

Устанавливаем курсор в ячейку G2 и вводим символ “=”. Для Excel это значит, что на данный момент будет введена формула. Потому как лишь дальше будет нажата буковка “е”, мы получим предложение выбрать функцию, начинающуюся данной буковкы. Избираем “ЕСЛИ”.

Далее все наши деяния также будут сопровождаться подсказками.

В качестве первого аргумента записываем: С2=”Запад”. Как и в остальных функциях Excel, адресок ячейки можно не вводить вручную, а просто кликнуть на ней мышкой. Потом ставим “,” и указываем 2-ой аргумент.

Второй аргумент – это значение, которое воспримет ячейка G2, ежели записанное нами условие будет выполнено. Это будет слово “Местные”.

После этого опять через запятую указываем значение третьего аргумента. Это значение воспримет ячейка G2, ежели условие не будет выполнено: “Экспорт”. Не забываем окончить ввод формулы, закрыв скобку и потом нажав “Enter”.

Наша функция смотрится последующим образом:

=ЕСЛИ(C2=”Запад”,”Местные”,”Экспорт”)

Наша ячейка G2 приняла значение «Местные».

Теперь нашу функцию можно скопировать во все другие ячейки столбца G.

А ежели один из характеристик не заполнен?

Если вас не интересует, что будет, к примеру, ежели интересующее вас условие не выполняется, тогда можно не вводить 2-ой аргумент. К примеру, мы предоставляем скидку 10% в случае, ежели заказано наиболее 100 единиц продукта. Не указываем никакого аргумента для варианта, когда условие не выполняется.

=ЕСЛИ(E2>100,F2*0.1)

Что будет в результате?

Насколько это прекрасно и комфортно – судить для вас. Думаю, лучше все же употреблять оба аргумента.

И в случае, ежели 2-ое условие не выполняется, но делать при этом ничего не необходимо, вставьте в ячейку пустое значение.

=ЕСЛИ(E2>100,F2*0.1,””)

Однако, таковая конструкция может быть применена в том случае, ежели значение «Истина» либо «Ложь» будут применены иными функциями Excel в качестве логических значений.

Обратите также внимание, что приобретенные логические значения в ячейке постоянно выравниваются по центру. Это видно и на скриншоте выше.

Читайте также  Флешку в жесткий диск в windows 7. Как сделать флешку жестким диском?

Более того, ежели для вас вправду необходимо лишь проверить какое-то условие и получить «Истина» либо «Ложь» («Да» либо «Нет»), то вы сможете применять последующую конструкцию –

=ЕСЛИ(E2>100,ИСТИНА,ЛОЖЬ)

Обратите внимание, что кавычки тут употреблять не необходимо. Ежели вы заключите аргументы в кавычки, то в итоге выполнения функции Ежели вы получите текстовые значения, а не логические.

Рассмотрим, как ещё можно употреблять функцию ЕСЛИ.

Использование функции Ежели с числами.

Точно так же, как мы это делали с текстом, в аргументах функции можно употреблять и числа.

Однако для нас принципиально то, что функция Ежели дозволяет не лишь заполнять ячейки определёнными числовыми значениями в зависимости от выполнения условия, но также и создавать некие вычисления.

К примеру, мы предоставляем нашему покупателю скидку в зависимости от суммы покупки. Ежели сумма больше 100, то он получает скидку 10%.

Назовём столбец Н “Скидка” и в ячейку H2 введём функцию Ежели, вторым аргументом которой будет формула расчёта скидки.

=ЕСЛИ(E2>100,F2*0.1,0)

Функция ЕСЛИ: примеры с несколькими условиями.

Итак, мы разобрались, как работает эта одна из самых нередко применяемых функций. Рядовая формула Ежели, которая инспектирует одно условие, чрезвычайно проста и проста в написании. 

Но что, ежели ваши данные требуют наиболее сложных логических проверок с несколькими условиями? В этом случае вы сможете включить несколько функций Ежели в одну формулу, и это будет называться вложенными критериями, собственного рода «ЕСЛИ в ЕСЛИ». Самым огромным преимуществом такового подхода является то, что он дозволяет инспектировать наиболее 1-го условия и возвращать различные значения в зависимости от результатов этих проверок, и все это при помощи одной формулы.

Вот обычный пример «ЕСЛИ в ЕСЛИ». Предположим, у вас в таблице Excel есть перечень студентов в столбце A и их оценки по тестам в столбце B. Вы желаете классифицировать оценки по последующим условиям:

  • «Отлично»: наиболее 249 баллов
  • «Хорошо»: от 249 до 200 включительно
  • «Удовлетворительно»: от 199 до 150 включительно
  • «Плохо»: до 150.

А сейчас давайте напишем вложенную функцию Ежели на базе вышеуказанных критериев. Хорошей практикой считается начинать с самого принципиального условия и очень упростить свои функции. Наша вложенная формула IF в Excel смотрится последующим образом:

=ЕСЛИ(B2>249; “Отлично”; ЕСЛИ(B2>=200; “Хорошо”; ЕСЛИ(B2>150; “Удовлетворительно”; “Плохо”)))

Многие считают, что вложенные условия очень сложны.  Попробуйте посмотреть на это под иным углом:

=ЕСЛИ(B2>249; “Отлично”;

 ЕСЛИ(B2>=200; “Хорошо”;

ЕСЛИ(B2>150; “Удовлетворительно”; “Плохо”)))

На самом деле формула показывает Excel, что необходимо выполнить логическую проверку первого условия и, ежели оно выполнено, вернуть значение, указанное в   аргументе ИСТИНА . Если условие 1-й проверки не выполнено, то проверьте 2-е выражение, и так далее.

ЕСЛИ ( проверить, если B2> = 249,  если ИСТИНА – вернуть  «отлично»,  или же 
ЕСЛИ ( проверить, если B2> = 200,  если ИСТИНА – вернуть  «хорошо»,  или же
ЕСЛИ ( проверить, если B2> 150,  если ИСТИНА – вернуть  «Удовлетворительно», если Ересь –
вернуть
  «Плохо»)))

Вложенные условия с математическими выражениями.

Вот еще одна обычная задача: стоимость за единицу продукта меняется в зависимости от его количества. Ваша цель состоит в том, чтоб написать формулу, которая вычисляет стоимость для хоть какого количества продуктов, введенного в определенную ячейку. Другими словами, ваша формула обязана проверить несколько критерий и выполнить разные вычисления в зависимости от того, в какой спектр суммы заходит указанное количество товара.

Эта задачка также может быть выполнена с помощью пары вложенных функций ЕСЛИ. Логика та же, что и в приведенном выше примере, с той только различием, что вы умножаете указанное количество на значение, возвращаемое вложенными критериями (т.е. соответственной ценой за единицу).

Предполагая, что количество записывается в B8, формула будет такая:

=B8*ЕСЛИ(B8>=101; 12; ЕСЛИ(B8>=50; 14; ЕСЛИ(B8>=20; 16; ЕСЛИ( B8>=11; 18; ЕСЛИ(B8>=1; 22; “”)))))

И вот результат:

Как вы осознаете, этот пример показывает лишь общий подход, и вы сможете просто настроить эту вложенную функцию в зависимости от вашей определенной задачи.

Например, заместо «жесткого кодирования» цен в самой формуле можно ссылаться на ячейки, в которых они указаны (ячейки с B2 по B6). Это дозволит редактировать начальные данные без необходимости обновления самой формулы:

=B8*ЕСЛИ(B8>=101; B6; ЕСЛИ(B8>=50; B5; ЕСЛИ(B8>=20; B4; ЕСЛИ( B8>=11; B3; ЕСЛИ(B8>=1; B2; “”)))))

Объединяем несколько условий.

Для того, чтоб обрисовать условие в функции Ежели, Excel дозволяет употреблять наиболее сложные конструкции. В том числе можно применять и несколько критерий. При этом еще воспользуемся тем, что функции можно “вкладывать” вовнутрь друг друга.

Для объединения пары критерий в одно используем логические функции ИЛИ и И. Разглядим обыкновенные примеры.

Пример 1

Функция Либо возвращает ИСТИНА, ежели хотя бы одно из перечисленных в ней пары критерий выполняется.

=ЕСЛИ(ИЛИ(C2=”Восток”,C2=”Юг”),”Экспорт”,”Местные”)

Вставляем функцию Либо как условие в функцию Ежели. В нашем случае, ежели регион покупателя – Восток либо Юг, то отгрузка считается экспортом.

Пример 2.

Используем несколько наиболее сложных критерий снутри функции Ежели.

Если регион реализации – Запад либо Юг, и количество при этом больше 100, то предоставляется скидка 10%.

=ЕСЛИ(И(ИЛИ(C2=”Запад”,C2=”Юг”),E2>100),F2*0.1,0)

Функция И возвращает ИСТИНА, ежели выполняются все перечисленные в ней условия. Вовнутрь функции И мы помещаем два условия:

  1. Регион – либо Запад либо Юг
  2. Количество больше 100.
Читайте также  Игры на айфон топ 10 бесплатных. Лучшие игры на iOS (iPhone/iPad)

Первое из их реализуем так же, как это было изготовлено в первом примере: ИЛИ(C2=”Запад”,C2=”Юг”)

Второе – тут всё чрезвычайно просто: E2>100

В строке 2, 3 и 5 выполнены оба условия. Эти покупатели получат скидку.

В строке 4 не выполнено ни 1-го. А в строке 6,7,8 выполнено лишь 1-ое, а вот количество очень не много. Потому скидка будет равна нулю.

Пример 3.

Конечно, эти несколько критерий могут быть и наиболее сложными. Ведь логические функции можно “вкладывать” друг в друга.

Например, в дополнение к предыдущему условию, скидка предоставляется лишь на темный шоколад.

Все наше записанное ранее условие становится в свою очередь первым аргументом в новейшей функции И:

  1. Регион – Запад либо Юг и количество больше 100 (рассмотрено в примере 2)
  2. В заглавии шоколада встречается слово “черный”.

В итоге получаем формулу Ежели с несколькими условиями:

=ЕСЛИ(И(ЕЧИСЛО(НАЙТИ(“Черный”,D2)),
И(ИЛИ(C2=”Запад”,C2=”Юг”)),E2>100),F2*0.1,0)

Функция Отыскать отыскивает четкое совпадение. Ежели же регистр знаков в тексте для нас не важен, то заместо Отыскать можно применять аналогичную функцию СОВПАД.

=ЕСЛИ(И(ЕЧИСЛО(СОВПАД(“черный”,D2)),
И(ИЛИ(C2=”Запад”,C2=”Юг”)),E2>100),F2*0.1,0)

В итоге, количество вложенных друг в друга критерий в Excel может быть чрезвычайно огромным. Принципиально лишь точно соблюдать логическую последовательность их выполнения.

Производим вычисления по условию.

Чтобы выполнить действие лишь тогда, когда ячейка не пуста (содержит какие-то значения), вы сможете применять формулу, основанную на функции Ежели.

В примере ниже столбец F содержит даты завершения закупок шоколада.

Поскольку даты для Excel – это числа, то наша задачка состоит в том, чтоб проверить в ячейке наличие числа.

Формула в ячейке F3:

=ЕСЛИ(СЧЁТЗ(D3:D9)=7,СУММ(C3:C9),””)

Как работает эта формула?

Функция СЧЕТЗ (английский вариант – COUNTA) подсчитывает количество значений (текстовых, числовых и логических) в спектре ячеек Excel. Ежели мы знаем количество значений в спектре, то просто можно составить условие. Ежели число значений равно числу ячеек, означает, пустых ячеек нет и можно создавать вычисление. Ежели равенства нет, означает есть хотя бы одна пустая ячейка, и вычислять нельзя.

Согласитесь, что нельзя именовать этот метод определения наличия пустых ячеек комфортным. Ведь число строк в таблице может поменяться, и необходимо будет поменять формулу: заместо числа 7 ставить другое число.

Давайте разглядим и остальные варианты. В ячейке F6 записана крупная формула -3

=ЕСЛИ(ИЛИ(ЕПУСТО(D3),ЕПУСТО(D4),ЕПУСТО(D5),ЕПУСТО(D6),
ЕПУСТО(D7),ЕПУСТО(D8),ЕПУСТО(D9)),””,СУММ(C3:C9))

Функция ЕПУСТО (английский вариант – ISBLANK) инспектирует, не ссылается ли она на пустую ячейку. Ежели это так, то возвращает ИСТИНА.

Функция Либо (английский вариант – OR) дозволяет объединить условия и указать, что нам довольно того, чтоб хотя бы одна функция ЕПУСТО нашла пустую ячейку. В этом случае никаких вычислений не производим и функция Ежели возвращает пустую строчку. В неприятном случае – производим вычисления.

Все довольно просто, но перечислять кучу ссылок на ячейки не очень комфортно. К тому же, тут, как и в прошлом случае, формула не масштабируема: при изменении таблицы она нуждается в корректировке. Это не очень комфортно, да и запамятовать можно сделать это.

Рассмотрим сейчас наиболее всепригодные решения.

=ЕСЛИ(СЧИТАТЬПУСТОТЫ(D3:D9),””,СУММ(C3:C9))

В качестве условия в функции Ежели мы используем СЧИТАТЬПУСТОТЫ (английский вариант – COUNTBLANK). Она возвращает количество пустых ячеек, но хоть какое число больше 0 Excel интерпретирует как ИСТИНА.

И, в конце концов, еще одна формула Excel, которая дозволит создавать расчет лишь при наличии непустых ячеек.

=ЕСЛИ(ЕЧИСЛО(D3:D9),СУММ(C3:C9),””)

Функция ЕЧИСЛО ( либо ISNUMBER) возвращает ИСТИНА, ежели ссылается на число. Естественно, при ссылке на пустую ячейку возвратит ЛОЖЬ.

А сейчас поглядим, как это работает. Заполним таблицу недостающим значением.

Как видите, все наши формулы рассчитаны и возвратили схожие значения.

А сейчас разглядим как проверить, что ячейки не пустые, ежели в их могут быть записаны не лишь числа, но и текст.

Итак, перед нами уже знакомая формула

=ЕСЛИ(СЧЁТЗ(D3:D9)=7,СУММ(C3:C9),””)

Для функции СЧЕТЗ не имеет значения, число либо текст употребляются в ячейке Excel.

=ЕСЛИ(СЧИТАТЬПУСТОТЫ(D3:D9),””,СУММ(C3:C9))

То же можно огласить и о функции СЧИТАТЬПУСТОТЫ.

А вот 3-ий вариант – к проверке условия при помощи функции ЕЧИСЛО добавляем проверку ЕТЕКСТ (ISTEXT в британском варианте). Объединяем их функцией ИЛИ.

=ЕСЛИ(ИЛИ(ЕТЕКСТ(D3:D9),ЕЧИСЛО(D3:D9)),СУММ(C3:C9),””)

А сейчас вставляем в ячейку D5 недостающее значение и проверяем, все ли работает.

Итак, мы с вами удостоверились, что обычная на 1-ый взор функция Ежели дает нам на самом деле много способностей для операций с данными.

Надеемся, этот материал был полезен. А вот еще несколько примеров работы с критериями и функцией Ежели в Excel.

Примеры использования функции ЕСЛИ:

Сравнение ячеек в Excel-Вы узнаете, как ассоциировать значения в ячейках Excel на предмет четкого совпадения либо без учета регистра. Мы предложим для вас несколько формул для сравнения 2-ух ячеек по их значениям, длине либо количеству…
Как проверить корректность ввода данных в Excel?-Подтверждаем корректность ввода галочкой. Задача: При ручном вводе данных в ячейки таблицы инспектировать корректность ввода в согласовании с имеющимся перечнем допустимых значений. В случае правильного ввода в отдельном столбце ставить…
Функция ЕСЛИ: проверяем условия с текстом-Рассмотрим внедрение функции Ежели в Excel в том случае, ежели в ячейке находится текст. СодержаниеПроверяем условие для полного совпадения…

Оставьте комментарий